Issue
kcarectl --doctor
does not generate the key:
# kcarectl --doctor
Generating report...
Uploading...
Key:
Please, provide above mentioned key to KernelCare Support Team
Environment
- KernelCare
Solution
There are two possible situations that led to the inability to get a key.
-
The server has no access to the Internet due to the need to isolate the server for security reasons.
In this case, it is possible to generate a report offline and send it to Support by attaching the resulting files to the message.
If there are problems with the connection during the report download, the report will be saved locally in the /root/cl-report file. Accordingly, this report file can be sent to the Support service for analysis.
If for some reason the /root/cl-report file has not been created, you can force its generation by using the command:
# FORCE_OFFLINE=1 kcarectl --doctor
The expected output should be as follows:
# FORCE_OFFLINE=1 kcarectl --doctor
Generating report...
There was some connection errors. Please, provide /root/cl-report file to KernelCare Support Team
# ls -lah /root/cl-report
-rw-r--r--. 1 root root 220K Nov 3 15:17 /root/cl-report -
The server is not isolated from the Internet intentionally.
This situation can arise for various reasons, for example, due to prohibiting firewall rules or problems with access to the network due to an incident at the Internet service provider or data center.
A report will be generated anyway. It will be uploaded (to get a key) if https://doctor.cloudlinux.com/doctor/upload is accessible. And will be saved locally if https://patches.kernelcare.com/myip is not accessible. This means that it is worth checking the availability of these hosts on the side of the server under study, to do this, you must use the following commands:
# curl -I https://doctor.cloudlinux.com/doctor/upload
# curl -I https://patches.kernelcare.com/myip
The expected output should be as follows:
# curl -I https://doctor.cloudlinux.com/doctor/upload
HTTP/1.1 405 METHOD NOT ALLOWED
Date: Thu, 03 Nov 2022 10:17:14 GMT
Server: Apache
Allow: POST
Content-Type: text/html; charset=utf-8# curl -I https://patches.kernelcare.com/myip
HTTP/1.1 200 OK
Server: nginx/1.20.2
Date: Thu, 03 Nov 2022 10:17:28 GMT
Content-Type: text/plain
Content-Length: 13
Connection: keep-alive
Strict-Transport-Security: max-age=63072000; includeSubdomains
X-Frame-Options: DENY
X-Content-Type-Options: nosniffIn case you cannot contact these hosts, you should check your firewall settings (you can try to disable them and check the availability of hosts), network settings and, if necessary, contact your hosting provider or internet service provider to solve network problems.
Cause
This problem occurs because the servers do not have access to the Internet and therefore cannot communicate with our KernelCare servers.
Useful links
https://docs.tuxcare.com/live-patching-services/#kernelcare-doctor.
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